Amarok not updating collection

The other day I noticed that Amarok didn't update the collection so I tried to rescan it. So I tried:starting amarok from the command line to try to divine some clues from the output.reinstalling amarok.removing the config-files.purging amarok and installing it again.checking if it has anything to do with permissions.trying to use mysql instead of sql-litetrying the versions in stable and sid instead.

I lost the entire collection (Amarok can't find it that is, the files are all there). trying to run amarokcollectionscanner from the terminal.googeling until my eyes hurt and my fingers bled. There is no output concerning update or rescan when I start it in console and try it.

Anyway, I did think about upgrading Amarok but I have to go to experimental as it is not yet in unstable and it will pull quite a few dependencies with it.

aptitude install -t experimental amarok Reading package lists...

Depends: libgssapi-krb5-2 (= 1.64~beta1-13) but 1.7dfsg~beta3-1 is to be installed.

libqt4-xmlpatterns: Depends: libqt4-network (= 4.5.1-2) but 4:4.5.2-1 is to be installed.

Depends: libqt4-xml (= 4.5.1-2) but 4:4.5.2-1 is to be installed.

Depends: libqt4-dbus (= 4.5.1-2) but 4:4.5.2-1 is to be installed.

amarok not updating collection-80amarok not updating collection-55amarok not updating collection-50amarok not updating collection-53

This has been designed to get the best possible amarok build & install with no broken packages.In case you find that some of the libraries required by Amarok are missing, you should definitely fill a bug report.Anyway, KDE 3.x isn't supported in any meaningful way anymore.Other than that, there are no broken dependencies or recommended packages lacking on my system. No progress bar, no activity, no processes being started. Considering that there is a an executable called /usr/bin/amarokcollectionscanner which is supposed to be launched by amarokapp, and considering that I can at least get output when specifying a folder to scan (i.e. Well, in fact I didn't have any such packages installed so I tried it. I didn't reflect on it and pasted it in the first post on this thread.Has anyone else had these problems or does anyone have any ideas on how I can fix this? I also tried starting it as root and scanning the collection. it lists the files and their meta-data) I'm inclined to draw the conclusion that amarok does not launch amarokcollectionscanner properly. Just to be sure I installed both kdebindings-java and python-kde3 which I understand are the kde-bindings available and provide all DCOP packages. However, I upgraded KDE weeks ago so I'm running KDE 4.2 from the testing repo (though I never use it, I keep KDE-core installed so I can run some of the great KDE apps such as Amarok, Soundkonverter and K3b).

Leave a Reply